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This is a comprehensive resource for the Simon Support team, to handle the incoming requests from the property teams. Should you have any questions outside of this guide, feel free to reference the Mappedin Knowledge Base: https://support.mappedin.com/hc/en-us/categories/204306707-The-Mappedin-CMS. 

The following guide details a high level overview of the Mappedin CMS, and a detailed breakdown of the steps, specific to our use case, to make the following changes: 
· Understanding space ID/External ID
· Merging Polygons
· Splitting Polygons
· Assigning External ID’s to polygons
· Creating Canvas Bounds
· Updating Pathing
· Generating Perspectives
· Acquire Perspectives
· Uploading a new CAD file

Understanding Space ID/External ID
Simon Central syncs nightly to the Mappedin CMS, using the Space ID for each unit. A space ID corresponds to a physical space defined by the CAD map, and is what syncs with Mappedin’s data repository (CMS) nightly at 2AM. When our vendor, MappedIn, created our 3D maps they defined the Space ID for each polygon on the map. Please note that the Space ID from the CAD file should match the External ID entered for each polygon on the Mappedin map.

Merging Polygons
When do you need to merge polygons on the map?
When a tenant is expanding their space into another empty space adjacent to their current space. 

STEP 1
Before merging polygons, make sure you have the following information:
1. Which polygons are to be merged together.
2. The tenant and Space ID that is to be applied to the newly created polygon.

STEP 2
Merging polygons
1. Select the Polygon Layer
2. Navigate to Draw Mode (E). [image: /Users/ianrutherford2/Desktop/Images/Draw.png]
3. Hold the SHIFT button while left-clicking to select multiple polygons to merge. 
4. Click ‘Edit” from the menu bar.
5. Select Merge from the options.
Please Note: Polygons must be overlapping or connected on at least 1 plane in order to merge successfully.

Splitting Polygons
	When do you need to split a polygon on the map?
Sometimes a mall will lease a space to multiple tenants. Or the tenant subleases part of their rented space to a different company. When two or more tenants (legitimately) share a space ID AND it is not a store-in-store scenario, the polygons will need to be split. These tenants will have different entrances or store fronts. 
The problem is when you have multiple stores in the same space, it is a crapshoot which tenant will appear on the interactive map. We need to split these polygons so that both tenants will show.

STEP 1
Before splitting a polygon, make sure you have the following information:  
1. Where the polygon needs to be split. 
a. It doesn’t need to be perfect. Usually cutting it equally in half will suffice, but use your best judgement. 
2. Which half you need to put each tenant after the polygon is split. 
a. Ex: is GapKids on the left half or right half?
b. If the person did not provide this information you can try to cross reference our older maps, which you can still access from the website by clicking the download button. 
3. Where the entrance to the store is. 
a. The entrance may be pretty self-explanatory unless on a corner where it could have an entrance to multiple hallways.

When in doubt, ask the requestor for more details if you can’t figure it out.

STEP 2
Splitting a Polygon
1. Go to the polygon layer
2. Select the polygon that you want to split.
3. Move over into Split mode (Q). [image: /Users/ianrutherford2/Desktop/Images/Split.png]
4. Click ‘View’ in the menu banner
a. Hover over Grid and then select ‘Show Grid’ (G) and ‘Snap to Grid’(B).
i. This is optional, but highly recommended.
5. Select ‘New Line’ (I think this step is optional)
6. To split the polygon RIGHT click on the map to place a dot. Click on a point outside of the polygon, preferably on a grid line. Now place a second dot (by right clicking) on the other side of the polygon, preferably on the same grid line as the first, so you get a nice straight line. This will create a line through your polygon.
[image: ]
· More than two points can be used to split a polygon by right clicking. If a curved line is required, click and drag the circle in the middle of a straight line to introduce a curve.
6. If you made a mistake on your split line simply click the ‘Clear Lines’ button and try again. Or try to reposition the dots on either end of the line to place it in a new position. Use left-click and hold to select and drag into place.
7. Click the ‘Split’ button to cut the polygon in half along the line that you just drew.
8. Now you need to change the external ID for one half of the split polygon. Proceed onto the next section




Assigning External ID’s to polygons

By default, the two halves of the polygon you split should both have the same External ID as the original polygon. Now you need to change one of them to something different. So for example, let’s say you have 2 stores: Gap and GapKids both with the Space ID ‘100’. After you split the polygon in half you could keep Gap’s polygon at 100 and change the GapKids half to 100B. Just make sure you don’t label the External ID something that already exists.

How to change the polygon’s external ID:
1. Go to the polygon layer
2. Make sure you are in Select Mode. [image: /Users/ianrutherford2/Desktop/Images/Select.png]
3. Select the polygon you want to change.
4. A panel on the right side of your screen will appear.
5. Click into the External ID field and type the new ID (so in the example above you could change it from 100 -> 100B)

Attach stores to both polygons using Simon’s CMS
1. DO NOT SKIP THIS STEP. Now you need to update the Space ID in the Simon Database. Log into Simon Central and then go to the Space ID editor for that mall. 
a. Continuing on with the Gap & GapKids example: Keep Gap at space id’100’. Change GapKids to ‘100B’.
b. If you do not do this part then the next time MappedIn refreshes their data using our API. Skipping this step will result in locations not attaching to the proper polygons or being left off the map.
c. If you don’t know how to edit a space ID use the guide here: https://helpme.simon.com/hc/en-us/articles/217514486-Interactive-3D-Mall-Maps-Training-Guide
2. Now you need to create canvas layers for each polygon. Proceed to the next section

Creating Canvas Bounds
Canvas bounds are used to place text of tenant’s name over the polygon. If you placed a canvas on the polygon, the system will automatically render it onto our mall maps. The only situation is will not do this is if the store name is too long for the polygon. In this scenario, no text will show unless the user hovers over the polygon.

1. Go to the polygon layer and click the polygon you want to edit
2. Select Canvas mode (T). [image: /Users/ianrutherford2/Desktop/Images/Canvas.png]
3. The polygon may have already have canvases generated from before you split it. Make sure there is not stacked canvas, hiding another below it. You can click and drag the canvas using the dot in the middle to move it.
4. Resize the canvas to fit into the polygon, using the dots in the middle of the edges of the square. It doesn’t need to cover the entire polygon, just try to get the biggest rectangle size possible.
5. Now click the 2nd polygon and apply a canvas to that. You can create a new canvas by clicking the ‘Generate’ button in the right-pane
6. If you need to delete a canvas, select the canvas and click the remove button in the right-pane.
7. If you make a mistake and want to undo your change, you can always click CTRL+Z on your keyboard. Or navigate to Edit>Undo 
Make sure to keep the canvas’ green dot oriented towards the entrance. You can do this by clicking and dragging the corner dots.

[image: ]


Updating Pathing
Now we need to update the pathing. Pathing is used for point-to-point directions. So each polygon needs a pin, connected to the path, the pin needs to be designated as an entrance node (denoted by a green infill), and the pin needs to have a store attached.

1. Go to the Path layer
2. Change to Draw mode (E). [image: /Users/ianrutherford2/Desktop/Images/Draw.png]
3. I find it easiest to delete the existing node that was placed for the previous un-split polygon. Do this by clicking the node and pressing Delete on your keyboard
4. Click on the dotted line in the hallway outside the entrance of one of the stores. Now right click inside the polygon to place a pin. Try to place it close to the entrance like all of the other pins. Reorient the line if necessary.
5. Repeat step 4 for the other polygon
6. Now you should have 2 pins, one in each polygon. But they look like white circles, unlike the other stores that have green circles with a pin on them. You need to convert these to entrance nodes. See below:
a. (still in draw mode) Click the pin
b. Hold down CTRL + ALT on your keyboard
c. RIGHT-click the polygon that contains the node
d. You will notice the node’s circle become bigger. If you click onto another node you will noticed the one you just converted now shows with a green infill.
e. Now repeat for the other node
7. Now you need to attach locations (stores) to each entrance node:
a. Still in the Path layer, switch over into select mode (cursor icon)
b. Click on one of the entrance nodes. A pane will open on the right
c. Click into the Location field and search for the store you want to attach. Once it is added a pin will appear on the node
d. Repeat for the other tenant




















Generating Perspectives

Please only generate a new .obj/perspective if you're changing something physical on the map, like splitting a polygon. If all you did was edit a canvas layer or changing a path, all you need to do is save.

Generating perspectives is the last step to the process.

There will be 2 or 3 perspectives you need to generate, depending on the mall. Most malls will only have 2.
1. ‘Perspective’
2. ‘Website’
3. ‘Acquire’ (this one is only at a few malls like KoP or Florida Mall. It is used for our digital display kiosks which were developed by AcquireDigital.

Instructions:
1. Click the Perspective tab at the bottom to open a gray pull up menu
2. Click the Draw Icon
3. Click 3D Renderer from drop down
4. Check the box Generate OBJ
5. Click the button Generate Perspective
6. *Very important* On the popup click the button “Current Only”
7. This will take a few minutes per perspective, but you can queue them up. Continue on to do the remaining perspective(s). Remember, to do this for all floors as well.
8. Once it is done uploading you will see the Date/Time below the Perspective update
9. *Very Important* After they are done uploading, save the map again. Go to File >Save
10. The perspective view can be closed simply by clicking the tab on the menu labeled ‘Perspectives’

Acquire Perspectives
Generating a perspective for use on an interactive directory and for use on a website will require resizing the outdoor map image before each perspective can be rendered. This will ensure that the image of the outdoor map is optimized for use on either interactive directories or web and mobile platforms.
Creating the Acquire Perspective (for use on interactive directories)
· To begin, make sure you are in Select mode [image: /Users/ianrutherford2/Desktop/Images/Select.png] and then left-click on the ‘Base’ polygon in the map to select it.
· To select the ‘Base’ polygon, make sure that this layer is unlocked and is active in the drop-down layer menu.
· With the ‘Base’ polygon selected, choose the Images menu at the top left of the screen and choose the ‘Resize Selected Images’ option. Once the Resize Images menu appears on the screen, choose the ‘8192x8192’ option and then click the blue ‘Resize’ button. 
· When the Conversion Complete menu appears click the blue ‘OK’ button. The image of the outdoor map will now be resized and you can render the ‘Acquire’ perspective.
· To render the ‘Acquire’ perspective, open the Perspectives tab at the bottom center of the screen. Hover your cursor over the pencil in the top right corner of the Acquire perspective tile. Select ‘3D Renderer’ from the drop-down list that appears.
· When the 3D Renderer opens, make sure ‘Generate OBJ’ is checked off in orange at the bottom right of the screen. Be sure not to change any Lights, Camera, Action or Rendering settings in the 3D renderer. Then click the blue ‘Generate Perspective’ button at the bottom right of the screen.
· Wait for the blue notification to appear at the top of the screen which will read “Tiling Complete.” This will signal that the new Acquire perspective has been created. Once you have created the new Acquire perspective be sure to Save Map (CTRL + S) found in the File menu.
Creating the Website Perspective (for use on web or mobile platforms)
· To begin, left-click on the ‘Base’ polygon to select it. With the ‘Base’ polygon selected, choose the Images menu at the top left of the screen and choose the ‘Resize Selected Images’ option. Once the Resize Images menu appears on the screen choose the ‘2048x2048’ option and then click the blue ‘Resize’ button.
· When the Conversion Complete menu appears, click the blue ‘OK’ button. The image of the outdoor map will now be resized and you can render the ‘Website’ perspective.
· To render the ‘Website’ perspective, open the Perspectives tab at the bottom center of the screen. Hover your cursor over the pencil in the top right corner of the Website perspective tile. Select ‘3D Renderer’ from the drop-down list that appears.
· When the 3D Renderer opens, make sure the following settings on your screen match the settings circled in red below.

· Once you have ensured that the settings of the ‘Website’ perspective you are about to render are identical to the settings circled above, you can click the blue ‘Generate Perspective’ button at the bottom right of the screen.
· Wait for the blue notification at the top of the screen to appear, which reads “Tiling Complete.” This will signal that the Website perspective has been created. Be sure to Save Map (CTRL + S) found in the File menu.
Uploading a new CAD file

The CMS allows you to update the Basemap for any of the Simon properties. Please note, this should only be updated if there have been significant changes to any of the Space ID’s and you have received a new CAD file to upload. Since Mappedin made some changes to the original CAD file provided, please reach out to the Support Team if changes are needed to the basemap for the following properties: 



Montgomery Mall
St Charles Towne Center
Circle Centre
Quaker Bridge
Ross Park Mall
Tuttle Crossing
Oxford Valley
Lehigh Valley
South Hills Village
The Avenues
Haywood Mall
Lenox Square
Mall of Georgia
Town Center at Cobb
Clarksburg PO
Livingston Mall
Shops at Nanuet
Menlo Park
Rockaway
Town Square
Roosevelt Field Mall
The Westchester
White Oaks Mall
Orland Square
Independence Center
Towne East Square
Southridge Mall
Woodfield Mall
The Domain
King of Prussia
Del Amo

For all other properties, refer to the following directions when you need to upload a new CAD file to replace the basemap:
· Export the CAD file as a PDF
Note: Be sure to use the exact same settings as the original floor plan that was provided to Mappedin. The interior file size should be 1224x792. 
· Verify that the x,y location of your mall, as well as the scale within the page match up with the settings of the venue’s initial export. If not, your basemap may appear shifted away from your polygons once uploaded.
· In the Mappedin CMS, navigate to the specific property.
· Under the Mapping Tab, select the Maps menu. 
· Select the correct floor.
· Under the Map Image field, select Upload or drag and drop your .PDF file into the box.
Note: The CMS will automatically convert this file to a .PNG and multiple the size to reflect the previous upload. Do not alter the settings in the Map Image field in any way.
· Click Save, to apply the changes.

[image: Screen%20Shot%202017-01-09%20at%202.21.59%20PM.png]


[bookmark: _GoBack]If a major renovation has occurred and the scale of the CAD file has changed (perhaps everything is slightly smaller within the 1224x792 size, to fit the new development around the mall), please reach out to Mappedin to help support this update. 
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